17.11.2018, 10:43 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

18.10.2007, 17:22

USB-Platte wird nicht erkannt

Moin,

folgende Situation. Ich habe hier ein Notebook von 'nem Kumpel das nicht mehr starten will. Um trotzdem an die Daten auf der Platte zu kommen habe ich diese ausgebaut und in ein externes USB-Geh?use geschraubt. Beim einstecken in den Rechner braucht dieser tierisch lange, um das Laufwerk ?berhaupt zu erkennen und WinXP m?chte den Vorgang gerne mit einem TimeOut beenden. Wenn es dann endlich erkannt wird kann ich die Daten von der D-Partition problemlos sichern, aber auf die Systempartition bekomme ich keinen Zugriff. Also habe ich mir gedacht, probierstes mal mit Knoppix. Aber leider erkennt Knoppix das Laufwerk ?berhaupt nicht. Habs mit einer anderen Platte ausprobiert, kein Problem. Woran kann das liegen?

Beide Platten sind FAT32 formatiert und waren beim booten bereits eingesteckt. Knoppix habe ich in der Version 5.1.

Tschau -Marco-

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

2

18.10.2007, 18:16

Hi,

m?glicherweise ist deine Platte defekt.
Nimm sie mal wieder aus dem USB-Geh?use raus, und schlie? sie als Slave an deinen prim?ren IDE-Kanal an.
Sollte der Kontroller wirklich einen weg haben, kann es klappen, da der Kontroller des Masters dann die Arbeit ?bernimmt.

M?glicherweise ist aber auch deine Partitionstabelle defekt.
Dann k?nnte dir ein testdisk helfen, wenn die Platte wenigstens erkannt w?rde.

Sind leider etwas sp?rliche Daten, aber mangels fehlender Fehlermeldung nicht besser m?glich.

HtH
Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

3

18.10.2007, 18:52

Zitat

m?glicherweise ist deine Platte defekt.

Die Idee ist mir auch schon gekommen, aber auf die 2te Partition kann ich ja problemlos zugreifen.

Zitat

Nimm sie mal wieder aus dem USB-Geh?use raus, und schlie? sie als Slave an deinen prim?ren IDE-Kanal an.

Mangels eines passenden Adapters kann ich das leider nicht.

Zitat

Sind leider etwas sp?rliche Daten, aber mangels fehlender Fehlermeldung nicht besser m?glich.

Fehlermeldung beim erkennen der Platte:
Ger?t-Zeit?berschreitung
Das Zeitlimit des angegebenen E/A-Vorgangs auf \Device\Harddisk1\DR5 wurde erreicht, bevor der E/A-Vorgang abgeschlossen wurde.


Fehlermeldung beim Anklicken des Laufwerks:
Auf G:\ kann nicht zugegriffen werden.
Das Zeitlimit f?r die Semaphore wurde erreicht.


Beide Fehlermeldungen nat?rlich unter Windows!

Tsch? -Marco-

4

23.10.2007, 01:35

So, hab mir jetzt einen passenden Adpater besorgt. Die Festplatte ist jetzt als Master am prim?ren IDE-Kanal angeschossen. Als Slave ging nicht, weil keine passende Platte da die ich als Master h?tte einsetzen k?nnen.

Die Ausgabe von fdisk -l
[code:1]root@Knoppix:/ramdisk/home/knoppix# fdisk -l

Platte /dev/hda: 100.0 GByte, 100030242816 Byte
255 K?pfe, 63 Sektoren/Spuren, 12161 Zylinder
Einheiten = Zylinder von 16065 ? 512 = 8225280 Bytes

Ger?t boot. Anfang Ende Bl?cke Id System
/dev/hda1 1 383 3076416 12 Compaq Diagnostics
/dev/hda2 * 384 6258 47190937+ c W95 FAT32 (LBA)
/dev/hda3 6259 12161 47415847+ f W95 Erw. (LBA)
/dev/hda5 6259 12161 47415816 b W95 FAT32

Platte /dev/sda: 320.0 GByte, 320072933376 Byte
255 K?pfe, 63 Sektoren/Spuren, 38913 Zylinder
Einheiten = Zylinder von 16065 ? 512 = 8225280 Bytes

Ger?t boot. Anfang Ende Bl?cke Id System
/dev/sda1 * 1 15298 122881153+ 7 HPFS/NTFS
/dev/sda2 15299 38913 189687487+ 7 HPFS/NTFS[/code:1]
Auf hda1 und hda5 kann ich problemos zugreifen. Bei hda2 bekomme ich folgende Fehlermeldung:
> Laufwerk kann nicht eingebunden werden.
> Die Fehlermeldung lautet
> mount: I could not determine the filesystem type, and none was specified

RalfonLinux

Erleuchteter

Beiträge: 2 934

Geschlecht: Männlich

5

23.10.2007, 18:22

Bist du dir den sicher, das hda2 ein FAT32 war ?
Nur weil in der Partitionstabelle FAT32 steht, kann in der Partition auch was anders drinne sein.

Vielleicht hilft dir ein [code:1]su
dd if=/dev/hda3 bs=512 count=10 | hexdump -C[/code:1]
Kannst du was erkennen ?

Dann k?nntest du versuchen, mit dem entsprechenen fsck.... noch was zu retten.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop