24.09.2018, 16:29 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

07.02.2010, 16:54

Festplattenprobleme

Hi!



Ich bin normalerweise ein Windoof Nutzer, aber mit dem hab ich ein Problem. Habe ein Programm installiert und nach nem Neustart kommt jetzt nur noch eine Bootschleife (davor hat es aber problemlos funtioniert). Dann habe ich wie so oft zuvor mit Knoppix (5.2) meine Daten in Sicherheit gebracht. Wollte schließlich Windows neu draufhauen, was aber nicht funktioniert hat weil meine erste Partition nicht erkannt wurde. Darum hab ich mich jetzt hier angemeldet und bitte euch um Hilfe. Da ich nicht noch mehr kaputt machen will, bitte ich euch bei der Hilfe um genaue Schritte - Danke.



PS: Die HDD ist momentan in einem externen USB Gehäuse und wird als SDB1 erkannt.

2

07.02.2010, 19:09

Aus gegebenen Anlass...

Versuche doch mal

Quellcode

1
sudo testdisk


Weis allerdings nicht ob das in Knoppix 5.2 funktioniert oder ob du da nicht 6.2 benötigst.

3

07.02.2010, 20:21

Ja, das mit Testdisk hab ich schon gelesen, ist auch auf der CD vorhanden. Aber ich weis nicht so recht was ich dann machen soll ?(



[Create] -> Festplatte /dev/sdb wählen -> [Intel/PC Partition] -> [Analyse] -> dann bin ich hier...


...ich denke mal dann mit [Proceed] weiter, oder? Wenn ich das mache, sind die Festplatten dann in grün untersetzter Schrift. Die BOOT Partition hat ein * davor, die anderen beiden jewals ein L. Beim nächsten mal Enter drücken hab ich dann 4 Partitionen drin.



Wenn das bis dahin richtig war, weis ich ab jetzt nicht weiter.

4

07.02.2010, 23:19

Das sieht doch schon mal vielversprechend aus. Man kann also sagen das noch alles da ist und es gesichert werden kann.
Ich bin alles andere als ein Linux Fachmann, eher alles andere. Ich empfehle Dir die Doku zu Testdisk mal etwas genauer anzuschauen.

http://www.cgsecurity.org/wiki/TestDisk_DE

Ich habe die letzten 3 Tage nichts anderes getan als versucht meine 300 GB zu retten. Dies ist mir auch gelungen durch einfaches kopieren der Ordner.
Testdisk ist sehr mächtig und ja eigentlich dazu da die zerhackten Bootsektoren neu zu erstellen. Soweit bin ich gar nicht gekommen, bzw. es war nicht mehr möglich.

Ich hoffe dir wenigstens ein bisschen geholfen zu haben.

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

5

07.02.2010, 23:20

Hallo!

Auf der Seite http://www.cgsecurity.org/wiki/Schritt_f…ellungsbeispiel gibt es ein Wiederherstellungsbeispiel. Vielleicht hilft es weiter.

L bedeutet, dass die Partition eine logische Partition innerhalb der extended Partition 2 ist.

6

07.02.2010, 23:57

Also meine Daten konnte ich alles ohne Probleme auch ohne Testdisk sichern. Wenn ich aber Win neu installieren will gibt er mir folgende Meldung zur Festplatte - C: Partition1 [unbekannt] wenn ich die Auswähle will er erst formatieren. Hab das Format ca. ne ¾h laufen lassen ohne das auch nur ein % formatiert wurde, kriegt man das wieder hingebogen?

7

08.02.2010, 06:40

Wenn deine Daten gesichert sind, kannst du mit cfdisk als root die Partitionen bearbeiten. Mit mkfs.xxx kannst du auch schon formatieren...

8

08.02.2010, 23:55

Habe mal cfdisk /dev/sdb1 probiert - da kam erstmal FATALER FEHLER: Beschädigte primäre Partition 0: Partition fängt hinter dem Ende

Dann mit mkfs /dev/sdb1 kam erstmal folgendes...

Zitat

knoppix@Knoppix:~$ mkfs /dev/sdb1
mke2fs 1.40-WIP (14-Nov-2006)
Dateisystem-Label=
OS-Typ: Linux
Blockgröße=4096 (log=2)
Fragmentgröße=4096 (log=2)
9781248 Inodes, 19537040 Blöcke
976852 Blöcke (5.00%) reserviert für den Superuser
erster Datenblock=0
Maximum filesystem blocks=0
597 Blockgruppen
32768 Blöcke pro Gruppe, 32768 Fragmente pro Gruppe
16384 Inodes pro Gruppe
Superblock-Sicherungskopien gespeichert in den Blöcken:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424

Schreibe Inode-Tabellen: erledigt
Schreibe Superblöcke und Dateisystem-Accountinginformationen: erledigt

Das Dateisystem wird automatisch alle 26 Mounts bzw. alle 180 Tage überprüft,
je nachdem, was zuerst eintritt. Veränderbar mit tune2fs -c oder -t .



Nochmal mit cfdisk hinterher gings dann (denk ich mal).



Habe jetzt glaub ich etwas Mist produziert. Nachdem ich die Platte "wieder hatte" hab ich sie unter Win7 formatiert und noch ein Testprogramm drüber laufen lassen. Dies brachte ein Haufen fehlerhafte E/A Sektoren. Bei der google Suche wurde dann ein LowLevel format vorgeschlagen was ich auch angefangen hab. Nach 3 min. jedoch bemerkte ich erst, dass das Programm die gesamte Festplatte und nicht nur die eine Partition formatieren wollte. Allerdings hatte ich die Daten auf den anderen beiden Partitionen nicht gesichert, da ich dachte das da nix rankommt - falsch gedacht. Jetzt wird die PLatte nur noch als /dev/sdb erkannt, kann man das wieder rückgängig machen?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Onkel Rumpel« (09.02.2010, 01:41)


klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

9

09.02.2010, 19:15

Wenn Du den Rechner schnell ausgeschaltet hast, könnte noch etwas zu retten sein. Anderenfalls ist die Festplatte wohl mit Nullen überschrieben und hat eine neue Tabelle, in der die defekten Bereiche eingetragen sein sollten. Du könntest im ersten Fall nochmal testdisk versuchen. Im zweiten Fall hilft vielleicht ein Datenrettungsspezialist, was aber teuer sein dürfte.

10

09.02.2010, 20:11

man cfdisk
man mkfs

11

10.02.2010, 00:00

Hatte die Platte bei ca. 15-20% aus dem USB Port gezogen und Testdisk konnte wieder retten *gottseidank* und ich habe jetzt auch die Daten der anderen Partitionen auf eine ext. HDD gezogen. Bekommt man die Fehlerhaften E/A Sektoren noch irgendwie anders in Griff?

Habe jetzt mal chkdsk drüber laufen lassen, das bringt folgendes...

Zitat

78148160 KB Speicherplatz auf dem Datenträger insgesamt
0 KB in 1 Dateien
4 KB in 9 Indizes
51992 KB in fehlerhaften Sektoren
68372 KB vom System benutzt
65536 KB von der Protokolldatei belegt
78027792 KB auf dem Datenträger verfügbar

4096 Bytes in jeder Zuordnungseinheit
19537040 Zuordnungseinheiten auf dem Datenträger insgesamt
19506948 Zuordnungseinheiten auf dem Datenträger verfügbar

Mächtig viele fehlerhafte Sektoren, oder?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Onkel Rumpel« (10.02.2010, 01:44)


klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

12

10.02.2010, 16:22

Nachdem die wichtigen Daten gesichert wurden, könntest Du das Lowlevel-Formatierungsprogramm natürlich erneut starten. Die defekten Sektoren würden dabei höchst wahrscheinlich erkannt und von der weiteren Benutzung ausgeschlossen. Bei einer erneuten Partitionierung hättest Du dann vermutlich ein (fast) fehlerfreies Dateisystem. Dabei bleibt allerdings offen, ob sich nicht schon bald neue defekte Bereiche zeigen werden, die nahe den schon bekannten liegen. Falls auf der Festplatte wichtige Daten abgespeichert werden sollen, wäre der Austausch der Festplatte durch eine fabrikneue sicherlich eine Überlegung wert.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop