24.11.2017, 17:53 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

31.10.2010, 09:48

Externe Festplatte nach Knoppixgebrauch nicht mehr lesbar

Hallo,

ich brauche umbedingt Hilfe. Seit einer Woche kann ich auf die Festplatte meines IBM Notebooks nicht mehr zugreifen.
Sehr wahrscheinlich ist es ein Hardwarefehler weil verschiedene Programme I/O Errors ausgeben.
Ich habe auf der Festplatte Win XP. Über die Knoppix CD 6.2 habe ich den Rechner gestartet. Mit angeschlossen war eine Seagate FreeAgent über USB um Daten zu retten. Nun geht es auch schon garnicht mehr um meinen Notebook. Meine ext.Festplatte lässt sich jetzt auch nicht mehr lesen.
Folgendes habe ich gemacht:

Ich habe Knoppix benutzt um den Rechner von CD zu starten. Beide Festplatten wurden unter dem Filemanager erkannt. Auf meine FreeAgent konnte ich zugreifen. Alle Daten wurden angezeigt. Auf die Interne des Notebooks hatte ich keinen Zugriff.
Terminal geöffnet Testdisk gestartet. Interne Festplatte überprüft. Partition gefunden.Alles Grün. keine Anzeige der Daten mit P möglich. File System Seems Damaged.
Nun mit dem Filemanager einen Ordner auf der FreeAgent erstellt und und ein paar schon vorhandene Ordner der FReeAgent dort verschoben. Nun der Versuch über Terminalbefehl Daten der Notebookfestplatte auf die Freeagent zu kopieren.
Ergebnis: Es konnten nur ein bischen kopiert werden dann wurde abgebrochen aufgrund nicht lesbarer Sektoren(glaube ich) der Notebookfestplatte.
Naja mit FileManager auf die FreeAgent gegangen um zu schauen was den kopiert wurde und nichts neues gefunden.
Jetzt habe ich Knoppix beendet.
Am nächsten Tag habe ich die Freeagent erstmal an einen anderen Laptop mit WinXP angeschlossen. Hier wird sie als Lokaler Datenträger erkannt. Aber nicht mehr als FreeAgent und man kann auch nicht mehr zugreifen.Vorher hat sie an dem Laptop erkannt.Chkdsk funktioniert auch nicht. Erster Schreck.
Also Freeagent wieder an den Rechner mit Knoppix hochgefahren. Diesmal wird keine Festplatte mehr erkannt unter dem Filemanager. Zweiter Schreck
Unter fdisk -1 wird sie erkannt. Mit mount -t ntfs-3g /device/sdb1 /mnt kommt nur Failed access volume.

Was ist nur mit der FreeAgent passiert. Hier sind meine Sicherungen drauf. Kann mir igendjemand helfen?
Hat Knoppix etwas an der Platte verändert?
Arrrg.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »eybee« (31.10.2010, 10:26)


Beiträge: 711

Geschlecht: Männlich

2

31.10.2010, 11:06

Mache doch mal bitte ein Bild von der Anzeige der Datenträgerverwaltung (Systemsteuerung -> Verwaltung -> Computerverwaltung -> Datenträgerverwaltung), wenn die externe Platte angeschlossen ist, und stelle das hier rein. Das müsste etwa so aussehen:
[attach]526[/attach]
MfG. Cottonwood.

3

31.10.2010, 11:53

Also hier mal das Bild.
Es ist eigentlich eine 500 GB Festplatte aber es werden nur 465 angezeigt. Das ist eigentlich nur der freie Speicherplatz vor meinen Aktionen gewesen.
[attach]527[/attach]

Beiträge: 711

Geschlecht: Männlich

4

31.10.2010, 12:19

Lade dir das Programm PTEDIT32.exe hier runter: ftp://ftp.symantec.com/public/english_us…s/pq/utilities/ und starte es.

Suche nun nach deiner Partition. Da nur eine drauf ist, solltest du sie gleich finden. Wie ich es sehe, hast du eine primäre Partition. Würde es sich bei der verloren gegangenen Partition um eine logische und somit nicht primäre handeln, dann müsstest vorher die Anzeige durch Drücken auf 'GoToEPBR' wechseln.

Klicke nun in das Feld, das den Dateityp anzeigt und anschließend auf 'Set Type'. Wähle das Dateisystem aus ('07' für NTFS) und speichere die Änderungen über 'Save Changes' und beende das Programm.

Nach einem Reboot müßte die ehemalige Partition mit ihrem Inhalt wieder hergestellt sein.

Wenn du Fragen hast, mache Bilder und melde dich.
MfG. Cottonwood.

5

31.10.2010, 12:40

Hallo,
Erstmal Danke für die Antwort.
Gibt es bei der Verwendung des Programs die Gefahr Daten zu verlieren?
Wenn ich in dem Program die Festplatte auswähle steht da schon 07 drin.
Kannst Du Dir erklären wieso die Festplatte verändert wurde?
[attach]528[/attach]

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »eybee« (31.10.2010, 12:47)


Beiträge: 711

Geschlecht: Männlich

6

31.10.2010, 12:47

Gibt es bei der Verwendung des Programs die Gefahr Daten zu verlieren?


Du solltest das Programm natürlich nicht auf deine interne Platte loslassen. Ansonsten kannst du ja momentan nur gewinnen, oder?

Wenn ich in dem Program die Festplatte auswähle steht da schon 07 drin.


Das wundert mich. Denn wenn du dir das Bild der Datenträgerverwaltung ansiehst, dann hat deine interne Platte 2xNTFS, die externe aber nicht.

Kannst Du Dir erklären wieso die Festplatte verändert wurde?


Nein. Aber ich kann ja auch nicht nachvollziehen, was du mit Knoppix angestellt hast. Hattest du "testdisk" im Einsatz?
MfG. Cottonwood.

7

31.10.2010, 12:48

Achja und ist es bei dem Programm auch normal, dass nur die 476 erkannt werden?

8

31.10.2010, 12:52

Hallo Cottonwood,

Im ersten Beitrag habe ich die Abfolge der Geschehnisse beschrieben. Testdisk hatte ich im einsatz. Allerdings nur für die kaputte erste interne Festplatte und wollte dann Daten kopieren auf die externe. Das Einzige was ich unter Knoppix mit der externen Festplatte gemacht habe ist also nur der Versuch auf diese zu kopieren und unter dem Knoppix file manager einen Ordner zu erstellen und vorhandene Ordner zu verschieben.

9

31.10.2010, 12:55

Die Interne Festplatte hat gewollte zwei Partitionen. Fürs Betriebssystem,Programme und für Daten

Beiträge: 711

Geschlecht: Männlich

10

31.10.2010, 13:50

Achja und ist es bei dem Programm auch normal, dass nur die 476 erkannt werden?

Windows "erkennt" nur 465. Das hängt damit zusammen, dass die Plattenhersteller lügen. Sie sagen 500GB, verkaufen aber nur 500x1000x1000x1000 Bytes. 500GB sind aber 500x1024x1024x1024 Bytes. Wenn du 465,76x1024x1024x1024 rechnest, dann hast du vorne 500 stehen.

Die Interne Festplatte hat gewollte zwei Partitionen. Fürs Betriebssystem,Programme und für Daten

Das mit der Aufteilung ist so schon okay.

Was mich irritiert, das ist, dass XP kein NTFS anzeigt, wohl aber PTEDIT32. Wie sieht denn deine C-Partition unter PTEDIT32 aus? Und wie sieht die externe Platte unter testdisk aus?

// Edit: War deine externe Platte vielleicht bootfähig?
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (31.10.2010, 14:04)


11

31.10.2010, 16:38

So also meine Festplatte wurde nicht zum booten benutzt.
Die Festplatte wird von XP so erkannt.
[attach]529[/attach]

Sollte nicht die Festplatte unter Wechselmedien stehen?
Wenn ich Testdisk starte wird die Festplatte so erkannt:
[attach]530[/attach]
Musste noch die Geometrie von 255 auf 240 setzen.
Danach gibt es aber immer noch eine Warnung. Warum?
[attach]531[/attach]
Habe Testdisk trotzdem einmal durchlaufen lassen und es wird die Partition gefunden mit einem *davor.
Wie gesagt, mit P kann ich mir keine Daten anzeigen lassen.

Unter Powerquest wird c: so dargestellt.
[attach]532[/attach]

Beiträge: 711

Geschlecht: Männlich

12

31.10.2010, 19:26

Das Problem liegt offensichtlich hier:
[attach]533[/attach]

Das einzige Programm, dem ich momentan spontan zutraue, dass es die Platte retten kann, ist O&O Defrag.
Früher war die Testversion eine Zeit lang uneingeschränkt nutzbar. Wenn das noch so ist, solltest du es damit versuchen. Danach lohnt dann ja auch der Kauf. :whistling:
MfG. Cottonwood.

13

31.10.2010, 22:02

Also ich habe versucht das Program laufen zu lassen.
Problem: O&O Defrag erkennt meine Externe Festplatte nicht. Sie wird nicht mal aufgelistet.
Wie kann es nur sein, dass die Festplatte teils erkannt und teils nicht erkannt wird. Mal NTFS mal nicht.
Und alles nur weil ich mit Knoppix Daten von der Internen auf die Externe kopiert habe.

Beiträge: 711

Geschlecht: Männlich

14

31.10.2010, 22:49

[attach]534[/attach]
Alle anderen Daten sind plausibel. Aber mir ist das zu heiss, dir jetzt zu sagen, ob und wie du das (ggf. testweise) ändern kannst.

Vielleicht ist hier ja jemand, der sich mit testdisk besser auskennt als ich. Der sagen kann, ob und wie du das ändern kannst, ohne dass noch mehr kaputt geht.

Es besteht allerdings die Gefahr, dass Knoppix bereits au Basis der falschen Informationen in die Datei geschrieben hat. Ob dann dadurch bereits etwas zerstört wurde, ist schwer zu sagen.
MfG. Cottonwood.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Cottonwood« (31.10.2010, 22:56)


15

31.10.2010, 22:57

Ok,

dann Danke erstmal und vielleicht meldet sich ja noch jemand zu diesem Thema.

Beiträge: 711

Geschlecht: Männlich

16

01.11.2010, 11:15

Eben habe ich mal selbst mit testdisk experimentiert - und mir so nebenbei meine Notebook-Bootpartition zerschossen. :whistling:
Wohl dem, der ein Image hat. :D

Aber ich habe auch nebenbei etwas herausgefunden. Und zwar habe ich eine 120GB externe Festplatte mit einer einzigen primären NTFS-Partition belegt:
[attach]535[/attach] [attach]536[/attach]

Nach Enter habe ich dann die Platte durchsuchen lassen und er hat noch alte Einträge gefunden. Unter diesen hätte ich im nächsten Schritt auswählen können.
[attach]537[/attach] [attach]538[/attach]

Vielleicht findest du ja hier auch noch einen Eintrag mit der 255 und kannst damit deine Platte retten. Einen Versuch ist es wert.
MfG. Cottonwood.

FM_81

Fortgeschrittener

17

01.11.2010, 13:18

Musste noch die Geometrie von 255 auf 240 setzen.
Danach gibt es aber immer noch eine Warnung.
Warum "musstest" Du; das macht man nicht ohne Not? Und auch dann NUR wenn man GANZ GENAU weiß, warum!
Unter Powerquest wird c: so dargestellt.
Hatte Deine interne schon immer 240 Heads? Im Allgemeinen ist 254 (nicht unbedingt 255) doch OK? Gibt es für Dich eine Chance das rückgängig zu machen? Oder besser noch vorher ein Abbild zu ziehen?

Was die Partitionskennung angeht: 07 bedeutet, dass dort NTFS erwartet wird, nicht dass es zwingend dort ist, und erst recht nicht, dass es ein fehlerfreies Dateisystem ist.

Zitat

Es besteht allerdings die Gefahr, dass Knoppix bereits au Basis der falschen Informationen in die Datei geschrieben hat. Ob dann dadurch bereits etwas zerstört wurde, ist schwer zu sagen.
Das stimmt allerdings leider!

Die Komplettausgabe mit beiden angesteckten Platten von

Quellcode

1
fdisk -l
(kleines "L", keine "1") kann trotzdem nicht schaden.

MfG, FM_81
ACHTUNG!
Ihre Systemleistung reicht nicht aus, um einen BLUE-SCREEN zu erzeugen!
Möchten Sie statt dessen einen GREEN-SCREEN sehen?

---- [Ja] ---- [Nein] ---- [Weiß noch nicht] ----

18

01.11.2010, 17:55

Hallo FM_81,

Das Problem bei Testdisk ist, dass die folgende Warnung für meine Externe ausgegeben wird:
[attach]539[/attach]

Jetzt ändere ich die Geometrie von 255 auf 240, wie in der Testdisk Anleitung beschrieben.
Danach erhalte ich folgende Warnung:
[attach]540[/attach]

Meine erste Interne ist kaputt. Die wurde hier in diesen Beiträgen nicht behandelt. Die Interne die Du hier gesehen hast ist von einem zweiten Laptop. Da funktioniert die Interne.Und soweit ich Weiß haben die Internen IBM Platten auch nur 240.

Mit Knoppix auf meinem kaputten Laptop und der externen dran ergibt der Befehl fdisk -l folgendes:


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
knoppix@Microknoppix:~$ fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
240 heads, 63 sectors/track, 5168 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes
Disk identifier: 0xcccdcccd

   Device Boot  	Start     	End  	Blocks   Id  System
/dev/sda1   *       	1    	4542	34337488+   7  HPFS/NTFS
/dev/sda2        	4543    	5168 	4732560   12  Compaq diagnostics

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa4b57300

   Device Boot  	Start     	End  	Blocks   Id  System
/dev/sdb1           	1   	60801   488384001	7  HPFS/NTFS
knoppix@Microknoppix:~$


Hier wird allerdings meine Externe Festplatte mit 255 gekennzeichnet.

Allerdings habe ich Testdisk auf der Externen bis zum NICHTFUNKTIONIEREN nicht angewendet.
Ich habe lediglich versucht von meiner kaputten Festplatte auf die Externe zu kopieren.
Was da passiert ist weiß ich nicht. Testdisk habe ich dann erst später auf die Externe angewendet. Ohne zu schreiben.
Mich würde interessieren, warum fdisk meine Externe mit 255 erkennt und Testdisk 240 will und nach Geometrieänderung trotzdem der bad ending head angezeigt wird.

Beiträge: 711

Geschlecht: Männlich

19

01.11.2010, 20:12

Nach Enter habe ich dann die Platte durchsuchen lassen und er hat noch alte Einträge gefunden. Unter diesen hätte ich im nächsten Schritt auswählen können.


Ich glaube, der Punkt hiess "deeper search". Hattest du das mal versucht?
MfG. Cottonwood.

20

01.11.2010, 22:34

Ich mache gerade den deeper search. Mal sehen was dabei raus kommt. Ich habe die Heads jetzt trotz Warnung erstmal auf 255 gelassen. Testdisk schreibt eigentlich erst wenn man die Partition auf die Festplatte schreibt.
Werde mein Ergebniss einstellen.

21

01.11.2010, 23:13

Das ist das Ergebnis des deeper search mit 255:
[attach]542[/attach]
[attach]543[/attach]

Unter der zweiten kann ich sogar Daten sehen.
Jetzt frage ich mich was das bedeutet. Ich meine die Suche habe ich trotz Warnung der 255 Heads durchgeführt.
Warum sind zwei Partitionen vorhanden. Was passiert wenn ich jetzt die Zweite mit dem Write Befehl erstelle.

Beiträge: 711

Geschlecht: Männlich

22

01.11.2010, 23:17

Nur die 2. ist richtig. Mache da ein P rein und berichte, was unter XP beim Zugriff auf die Daten passiert.
MfG. Cottonwood.

FM_81

Fortgeschrittener

23

02.11.2010, 10:55

Eventuell (ich kam noch nie in die Verlegenheit TestDisk benutzen zu MÜSSEN) kann TestDisk immer nur mit einem Wert arbeiten, also entweder 240 (was für die interne richtig wäre) oder 255 (was für die externe OK sein sollte), wie gesagt, ist nur eine Vermutung ...

MfG, FM_81
ACHTUNG!
Ihre Systemleistung reicht nicht aus, um einen BLUE-SCREEN zu erzeugen!
Möchten Sie statt dessen einen GREEN-SCREEN sehen?

---- [Ja] ---- [Nein] ---- [Weiß noch nicht] ----

Beiträge: 711

Geschlecht: Männlich

24

02.11.2010, 15:04

Ich würde versuchen herauszufinden, mit welcher Einstellung die Platte für O&O Defrag sichtbar wird. Wenn das gelingt, dann sollte man das Laufwerk defragmentieren (meine Wahl wäre der Parameter Space). O&O Defrag ist in der Lage, eine Menge auf einer defekten Platte zu reparieren. Was danach nicht da ist, das ist auch nicht da. Höchstens noch für professionelle Datenretter. Aber wenn daran gedacht wird, sollte die Platte zu denen, ohne dass sie noch einmal angefasst wird.
MfG. Cottonwood.

25

02.11.2010, 22:23

So hab jetzt auf P geändert und dann kamm das

[attach]544[/attach]

was mach ich nu

Beiträge: 711

Geschlecht: Männlich

26

02.11.2010, 22:46

Nur die 2. ist richtig. Mache da ein P rein und berichte, was unter XP beim Zugriff auf die Daten passiert.

Sorry, das war nicht richtig. Da steht ja 254. Sollte aber 255 sein. Was passiert, wenn du das auf 255 änderst?
MfG. Cottonwood.

27

02.11.2010, 23:55

So nachdem ich die Warnung, dass 255 falsch sind ignoriert habe, sind bei Testdisk zwei Partitionen erschienen(wie in den Bildern weiter oben zu sehen)
Cottonwood hatte Recht, die zweite war die, die ich brauchte. Konnte mir über P eine Liste der Files anschauen. Waren allerdings nicht alle Dateien vorhanden. Trotzdem habe ich die Zweite Partition auf Primär gesetzt und auf write gedrückt. Dann kam noch die Fehlermeldung mit dem Boot Sektor. Die entstand, weil die erste Partition nicht mit derjenigen der Zweiten Partition aus dem Backup übereinstimmte. Also BS Backup gewählt. Danach sollte alles fertig sein. War aber nicht. weder Windows ließ mich auf die Daten und auch O&O erkannte die Festplatte garnicht. Also alles wie vorher, ausser dass ich nun nochmal chkdsk ausprobiert habe. Chkdsk hat jetzt nicht mehr wegen dem Dateisystem gemeckert. Irre viel hin und her gerödelt. Tja und was soll ich sagen. Meine Freeagent ist zu erkennen und alle Daten sind da soweit ich sehen kann. Mit ganz normalen Dateinamen. Jetzt mach ich erstmal ein Backup und stürz mich dann auf meine interne Festplatte mit dem I/O Error.
Danke für Eure Hilfe.

Gruß

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop