21.10.2018, 04:49 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

04.07.2011, 00:20

Kann nicht die von ntfsclone erzeugte Image-Datei restoren!

Hallo,

Ich hoffe hier wird mir weitergeholfen,denn ich weiß einfach nicht mehr weiter.
Naja also ich erklär mal so mein Problem:

Angefangen hatte es damit,dass ich meine Windowspartition erweitern wollte,da für Windows +Updates 12 GB anscheinend nicht mehr ausreichend sind. Also hab ich mit Knoppix und Gparted die Partition erweitern wollen,dies ging aber wegen einem "unbekannten Fehler" nicht. Also hab ich mit ntfsclone von jeder Partition Image-Dateien erstellt. Dann hab ich mit der Windows-CD die Festplatte neu partitioniert und wollte die Image-Dateien wieder draufspielen,aber ntfsclone erkennt diese nicht. Meine Image-Dateien befinden sich auf /dev/sdb2 und ich will /dev/sda1 wieder mit den Dateien bespielen,aber
ntfsclone --restore-image /dev/sdb2/backup.img --overwrite /dev/sda1
klappt einfach nicht und ich weiß einfach nicht was ich machen soll,ich bin ja recht unerfahren was das angeht,da hilft mir mein Halbwissen nicht weiter..

Danke schonmal im Vorraus!

MfG Henning

klaus2008

Meister

Beiträge: 2 695

Geschlecht: Männlich

2

04.07.2011, 01:40

Hallo, Henning!

Welche Knoppix-Version verwendest Du?

Zitat

Meine Image-Dateien befinden sich auf /dev/sdb2 und ich will /dev/sda1 wieder mit den Dateien bespielen,aber
ntfsclone --restore-image /dev/sdb2/backup.img --overwrite /dev/sda1
klappt einfach nicht
Welche Fehlermeldung erhälst Du?

Mit welchem Befehl hast Du die Sicherung durchgeführt?

Damit eine Datei unter Linux gefunden werden kann, muss zuerst die Laufwerkspartition in das Dateisystem eingebunden werden. Dafür gibt es den mount-Befehl:

Quellcode

1
mount /dev/sdb2 /media/sdb2
hängt die Partition /dev/sdb2 am (bereits existierenden) Einhängepunkt /media/sdb2 ein. In der grafischen Umgebung von Knoppix 6 kann man das Einbinden bequem mit dem Dateimanager erledigen.

Gemäß der Handbuchseite denke ich, dass der Befehl zur Wiederherstellung so aussehen sollte:

Quellcode

1
ntfsclone --restore-image --overwrite /dev/sda1 /media/sdb2/backup.img
Dabei wird angenommen, dass die Abbilddatei backup.img auf der Partition /dev/sdb2 im Wurzelverzeichnis abgespeichert, und diese Partition unter /media/sdb2 eingebunden wurde.

In der bereits erwähnten Handbuchseite steht noch folgender Abschnitt, der auf mögliche Probleme nach der "Wiederherstellung" hinweist:

Zitat


Windows Cloning

If you want to copy, move or restore a system or boot partition to another computer,
or to a different disk or partition (e.g. hda1->hda2, hda1->hdb1 or to a different
disk sector offset) then you will need to take extra care.

Usually, Windows will not be able to boot, unless you copy, move or restore NTFS to
the same partition which starts at the same sector on the same type of disk having
the same BIOS legacy cylinder setting as the original partition and disk had.

The ntfsclone utility guarantees to make an exact copy of NTFS but it won't deal with
booting issues. This is by design: ntfsclone is a filesystem, not system utility. Its
aim is only NTFS cloning, not Windows cloning. Hereby ntfsclone can be used as a very
fast and reliable build block for Windows clonning but itself it's not enough.


Gruss
Klaus

3

04.07.2011, 02:53

Danke für die schnelle Antwort!

Also ich benutze die Knoppix 6.4.3

die Fehlermeldung die ich im Terminal erhalte, ist:

Zitat

ERROR(2): failed to open image: Datei oder Verzeichnis nicht gefunden

und nachdem ich das Backup direkt in die zu wiederherstellene Partition getan hatte und direkt von dort restoren wollte:

Zitat

ERROR: Input file is not an image! (invalid magic)



Der Befehl zur Sicherung lautete:

Zitat

ntfsclone --save-image /dev/sda1 --output /dev/sbd2/backup.img


davor hab ich noch :

Zitat

umount /dev/sda1

eingegeben,da er meinte ich müsste es erst unmounten.

Oh und ich sehe gerade auf der von dir aufgelisteten Handbuchseite,dass ntsfclone nicht für Systempartitionen gedacht ist,es kann aber nicht daran liegen das ich versuche ein Backup einer Bootpartition wiederherzustellen,weil mit meinen anderen Backups der anderen Partitionen hat es auch nicht geklappt..

Edit:
Ah ich glaube ich bin ein Stück weiter,ich hab mal den Befehl,den du mir gegeben hast probiert,zumindest sagt er mir jetzt nur noch das

Zitat

Device '/dev/sda1' is mounted read-write. You must 'umount' it first.

und unmounten funktioniert jetzt scheinbar nicht da

Zitat

umount: /media/sda1: device is busy.


Ah okay ich hab einfach den Prozess beendet der auf die Partition zugreift,zumindest scheint er jetzt die Image-Datei wiederherzustellen.Falls noch irgendein Fehler auftreten sollte,schreib ichs hier rein.

Vielen vielen Dank trotzdem für den Befehl,ich hatte das mit dem "media" noch nicht gewusst, Danke!

Gruß Henning

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »donniedarko« (04.07.2011, 03:34)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop