20.09.2019, 23:14 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

RalfonLinux

Erleuchteter

Beiträge: 2 936

Geschlecht: Männlich

1

03.02.2005, 09:04

Umlaute gehen bei NTFS verloren

Hallo,

ist mir gerade mal so aufgefallen,
man nehme einen W2KSP4-Server, und gebe einen Ordner frei.
Innerhalb dieses Ordners erstellt man einen Unter-Ordner mit Umlauten ("BackUp nicht l?schen") und nun:
[code:1]
mount //srvde011/Freigabe /mnt/test -o username=thor%hammer,workgroup=walhalla
ls /mnt/test
[/code:1]
Ergibt unter KNOPPIX3.7 ein "BackUp nicht l?schen"
unter SuSE9.0 ein "BackUp nicht l?schen"

Also es ist m?glich, blo? KNOPPIX will/kann nicht.
Versuche mit [code:1]mount ....walhalla,iocharset=iso8859-1,codepage=850 o.?.[/code:1]
brachten keine zufriedenstellenden Ergebnisse.
Klaus ist doch auch ein Umlaute-Benutzer, wieso kann das dann KNOPPIX nicht ?

P.S.: Kommt jetzt nicht mit der L?sung ("BackUP nicht loeschen") ;-)
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

2

03.02.2005, 14:28

Das ist moeglicherweise ein Problem mit dem Terminal? konsole oder xterm?

RalfonLinux

Erleuchteter

Beiträge: 2 936

Geschlecht: Männlich

3

21.02.2005, 09:05

Hallo Brack,

hat etwas l?nger gedauert, aber war beruflich viel unterwegs.

Das Problem tritt in beiden F?llen auf, egal ab xterm oder echte Konsole. Ich habe das Problem aber jetzt auch gel?st.
Die richtige Syntax lautet:

[code:1] mount //srvde011/Freigabe /mnt/test -o username=thor%hammer,workgroup=walhalla,codepage=cp437[/code:1]

Wichtig ist in diesem Fall: codepage=cp437 und nicht codepage=850 o.?.

Man lernt doch nie aus ....


Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

4

23.11.2006, 10:26

Problem besteht weiterhin

Das Problem scheint mir nicht ganz gel?st.

Da ich als Administrator ?rger mit Berechtigungen von Dateien hatte und nicht alles per Kommandozeilentool regeln wollte (Besitz ?bernehmen, Rechte anpassen), habe ich einfach meine NTFS-Partition vom Knoppix 5.1 Desktop aus auf eine USB2-Platte mit ext2-Filesystem kopiert, damit die Attribute verloren gehen.

Diese Platte habe ich dann unter XP mit EXT2IFS eingebunden und dann auf die neu formatierte NTFS-Partition zur?ckkopiert. Klappte einwandfrei bis auf die Umlaute in Dateinamen, die nun mit einer anderen Codepage dargestellt werden. Das ? ist bspw. das "geteilt durch"-Zeichen, ? wird als "hoch 3" dargestellt usw.

Ich halte es nicht f?r ein Problem von EXT2IFS, da ich es auf meinem 2t-Rechner auch verwende und dort problemlos Dateien mit Umlauten zwischen beiden Filesystemen hin- und her kopieren kann.

RalfonLinux

Erleuchteter

Beiträge: 2 936

Geschlecht: Männlich

5

23.11.2006, 11:24

Werden sie dir den mit EXT2IFS auf der externen Platte als richtig angezeigt ?

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

Anonymous

unregistriert

6

23.11.2006, 12:22

Nein. Da ich aber auf meinem anderen System auf mit Ext2Inf eingebundene Volumes unter Win2000 Dateinamen mit Umlauten problemlos kopieren kann, gehe ich weiterhin davon aus, da? Knoppix beim Kopieren von NTFS auf Ext2 die Umlaute vermurkst hat.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop