21.06.2018, 11:53 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

16.11.2010, 16:48

Keine Pipe in Root-Shell

Hallo zusammen,

ich benutze Knoppix 6 als Live-System. Leider kann ich in der Root-Shell keine Pipe erstellen. Drücke ich "AltGr" + "<" zuckt die Shell kurz und das war es dann auch schon. Weder eine Pipe noch sonst was erscheint.

Wer kann helfen?

Grüße,
Michael

2

16.11.2010, 18:03

... ich kann mit Knoppix 6.2.1 weder in der Textkonsole noch im LXTerminal 0.1.6 dies beschriebene Verhalten nachvollziehen.
Was für Knoppix-Version (remastered?) benutzt du?
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

3

16.11.2010, 19:28

Remastered - kann ich nicht sagen. Ich hatte damals das ISO runtergeladen. Wo, weiß ich nicht mehr. Kann ich irgendwo die genaue Version rausfinden und ob die remastered ist?
Oder soll ich mir einfach nochmal die 6.2 von knopper.net runterladen?

Grüße,
Michael

4

16.11.2010, 22:58

... welche Knoppix-Version du hast, kannst du gleich im Startbildschirm sehen. Ob es sich allerdings um eine remastered Version handelt, läßt sich nicht einfach feststellen. Bei der von mir beschriebenen Methode kann man dies während des weiteren Starts der CD sehen, aber nicht jede Beschreibung des remastern macht dies auch so.

Im Zweifelsfall lade dir lieber die neueste Version samt md5-Datei von knopper.net
Gruß Werner * Eigene Rescue-CD
remaster Grml * remaster Knoppix

5

26.11.2010, 21:01

Habe inzwischen die Knoppix-Version 6.2 von knopper.net runtergeladen im ISO-File war noch ADRIANE angegeben. Ist aber genau dasgleiche: kein \ im Suse System selbst auf der Platte (v11.1) kein Problem.

Gruß,
Michael

klaus2008

Meister

Beiträge: 2 686

Geschlecht: Männlich

6

26.11.2010, 21:32

Hallo!

Verwendest Du eine spezielle Tastatur? Ist die Sprache auf de (Cheatcode lang=de) eingestellt? Funktionieren die Umlaute?

Gruss Klaus

7

27.11.2010, 13:51

"Verwendest Du eine spezielle Tastatur?"
Nein. Eher eine "klassische" Fujitsu-Tastatur. Ziemlich alt. Funktioniert an mehreren Rechnern mit Linux oder auch Windows ganz normal. Sprich: alle Zeichen verfügbar.

"Ist die Sprache auf de (Cheatcode lang=de) eingestellt?"
Konnte ich nicht nachvollziehen. Sorry... :whistling: Wie lautet der Befehl, um das aktuell aktive Tastaturlayout anzuzeigen?

"Funktionieren die Umlaute?"
Die Umlaute funktionieren einwandfrei - insofern denke ich, dass das Tastaturlayout passt (als Ergänzung zu vroiger Frage).

Neue Erkenntnisse meinerseits:
Das Problem beschränkt sich nur auf die Zeichen, die mit ALT-GR erzeugt werden sollen. Also ~|@€\µ.
Sobald ich im Terminal (keine Root-Shell) das Kommando setxkbmap ausführe sind alle Zeichen (insbesondere ~|@€\µ) verfügbar.

Insofern ist mein Problem mit diesem Workaround gelöst. Aber ich würde natürlich schon gern wissen, woran das liegt. Für Hinweise bin ich gern zu haben.

Grüße,
Michael

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop