15.08.2018, 13:01 UTC+2

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

06.05.2007, 10:44

X-Server startet nicht mehr - erledigt

Hallo Experten,

ich hatte ein Knoppix 3.6 als HD-Installation (Debian-artiges-System, Kernel 2.4.27) seit 2,5 Jahren stabil auf meinem Laptop zu laufen.

Nach einem System Update mit apt-get update und dem Versuch der Nachinstallation von Iceweasel mittels KPackage startet der X-Server nicht mehr. Da bei der Iceweasel-Installation zahlreiche Abh?ngigkeiten mitinstalliert wurden, denke ich dass dort das Problem liegt. Die Fehlermeldung lautet:

usr/X11R6/lib/X11/xinit/xserverrc: line 2: /usr/bin/X11/X: No such file or directory
usr/X11R6/lib/X11/xinit/xserverrc: line 2: exec: /usr/bin/X11/X: cannot execute: No such file or directory

Habe schon versucht, die originale Datei xserverrc von der CD zu verwenden, da steht aber das gleiche drin.

Gibt es eine M?glichkeit, das ganze Update sowie die Installation von der Konsole aus r?ckg?ngig zu machen (etwa wie "Systemwiederherstellungspunkt" bei dem anderen Betriebssystem?

2

06.05.2007, 12:05

Rueckgaengigmachen geht nicht.

Fuer mich sieht das so aus, als sei das komplette X-System entfernt worden.

Bei so einer alten Version weiss ich es nicht genau, aber was sagt er denn, wenn Du als root folgendes tippst:

apt-get install XFree86

Da muesste er eigentlich vorschlagen, einiges zu installieren. Oder aber er meckert, was ihn an der Installation hindert.

Poste am besten auch mal den Inhalt Deiner /etc/sources.list Datei

3

06.05.2007, 14:34

X-Server startet nicht mehr

Hallo Brack,

anbei der Inhalt meiner sources.list:

# /etc/apt/sources.list for Knoppix
# If you want to do a "full upgrade", you should first
# upgrade the Packages from Debian/unstable (KDE & Co.)
# before doing a (dist-)upgrade for Debian/testing.
#
# See sources.list(5) for more information, especialy
# Remember that you can only use http, ftp or file URIs
# CDROMs are managed through the apt-cdrom tool.

# Security updates for "stable"
deb http://security.debian.org stable/updates main contrib non-free
#deb http://security.debian.org testing/updates main contrib non-free
#deb ftp://ftp.tu-chemnitz.de/pub/linux/debian/debian stable/updates main contrib non-free

# Stable
deb http://ftp.de.debian.org/pub/debian stable main
#deb http://ftp.de.debian.org/pub/debian stable main contrib non-free
#deb http://ftp.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free

# Stable Sources
deb-src http://ftp.de.debian.org/pub/debian stable main
deb-src http://ftp2.de.debian.org/pub/debian stable main contrib non-free
deb-src http://ftp2.de.debian.org/pub/debian-non-US stable/non-US main contrib non-free
#deb ftp://ftp.tu-chemnitz.de/pub/linux/debian/debian stable main contrib non-free
#deb ftp://ftp.tu-chemnitz.de/pub/linux/debian/debian-non-US stable main contrib non-free

# Testing
#deb http://ftp.de.debian.org/pub/debian testing main contrib non-free
#deb http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

# Testing Sources
#deb-src http://ftp.de.debian.org/pub/debian testing main contrib non-free
#deb-src http://ftp.de.debian.org/pub/debian-non-US testing/non-US main contrib non-free

# Unstable
#deb http://ftp.de.debian.org/debian unstable main contrib non-free
#deb http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free

# Unstable Sources
#deb-src http://ftp.de.debian.org/debian unstable main contrib non-free
#deb-src http://ftp.de.debian.org/debian-non-US unstable/non-US main contrib non-free

# Experimental
#deb http://ftp.de.debian.org/debian ../project/experimental main contrib non-free

# Experimental Sources
#deb-src http://ftp.de.debian.org/debian ../project/experimental main contrib non-free

# Java
#deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
#deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian woody main non-free
#deb ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free
#deb-src ftp://ftp.gwdg.de/pub/languages/java/linux/debian unstable main non-free

# More wireless stuff
# deb http://debian.isg.ee.ethz.ch/public woody madwifi
# deb-src http://debian.isg.ee.ethz.ch/public woody madwifi
# deb http://debian.isg.ee.ethz.ch/public woody airo-mpi
# deb-src http://debian.isg.ee.ethz.ch/public woody airo-mpi
# deb ftp://ftp.tcweb.org/pub/debian unstable main
# deb-src ftp://ftp.tcweb.org/pub/debian unstable main

# NX stuff
# deb http://www.kalyxo.org/debian/ experimental main

# ndiswrapper
# deb http://rigtorp.se/debian unstable/
# deb-src http://rigtorp.se/debian unstable/

# Blades Repository (pppoeconf & co)
# deb http://people.debian.org/~blade/testing ./
# deb-src http://people.debian.org/~blade/testing ./

# deb cdrom:[Debian GNU/Linux 2.2 r3 _Potato_ - Official i386 Binary-1 (20010427)]/ unstable contrib main non-US/contrib non-US/main

# Knoppix special packages resource at LinuxTag HQ
# deb http://developer.linuxtag.net/knoppix ./
# deb-src http://developer.linuxtag.net/knoppix ./

# deb http://snapshot.debian.net/archive pool gcc
# deb-src http://snapshot.debian.net/archive pool gcc

4

06.05.2007, 16:30

Und was ist damit?

apt-get install XFree86

Oder evtl. wenn das nicht geht

apt-get install xorg

Wenn Dein Knoppix schon so alt ist, dann war damals wohl noch eine andere Version als "stable" gekennzeichnet. Ich weiss nicht, wie reibungslos das Update dann funktioniert. Da kann vielleicht jemand anderes weiterhelfen.

5

07.05.2007, 18:11

Hallo...,

apt-get install XFree86 wird mit Fehlermeldung und einem Hinweis auf apt-get -f install abgebrochen.

Wenn man dem folgt, l?dt er ca. 350MB Daten herunter, arbeitet ca. 20 min und endet dann in einer Fehlermeldung, die ich mangels Kopierm?glichkeit von der Textkonsole nicht wiedergeben kann.

Zus?tzlich kommt andauernd die Fehlermeldung, dass ich (sinngem??) die Parameter LANG, LC_ALL und LANGUAGE setzen soll. Keine Ahnung wie das geht und warum ich die bisher nicht gebraucht habe.

6

08.05.2007, 20:19

Nochmal Hallo Allerseits,

hat denn keiner eine Idee, wie das System mit X-Server wieder flott zu bekommen ist?

Ciao und Danke.

7

09.05.2007, 07:56

Ich denke, das mit LANG, LC_ALL und LANGUAGE kann man erstmal ignorieren. Vielleicht hat aber auch jemand anderes einen kurzen Tipp parat.

Ansonsten kann man immer wenig sagen, ohne die konkreten Fehlermeldungen.

Falls Kopieren nicht geht, geht denn Abfotografieren mit der Digicam? Und dann kannste die Bilder z.B. bei http://www.imageshack.us/ hochladen.

prh

Profi

Beiträge: 1 248

Geschlecht: Männlich

8

09.05.2007, 09:03

Zitat von »"tellofix"«

Nochmal Hallo Allerseits,

hat denn keiner eine Idee, wie das System mit X-Server wieder flott zu bekommen ist?

Ciao und Danke.
Hallo,
du koenntest die komplette Partition auf e. usb-Platte kopieren und dann noch mal neu installieren. Private Dateien wie z.B. Lesezeichen etc. gehen dann nicht verloren. In Zukunft vllt. mal an eine Sicherung (Partimage) denken bevor man solche Aktionen startet ;)
LG
prh

9

09.05.2007, 21:21

Zitat von »"tellofix"«

Nochmal Hallo Allerseits,

hat denn keiner eine Idee, wie das System mit X-Server wieder flott zu bekommen ist?

Ciao und Danke.


Das alte Teil bekommst du so garnicht mehr flott. Au?er neu installieren.

Was man eventuell noch versuchen k?nnte die /etc/apt/sources.list komplett zu l?schen und dann nur diesen Eintrag darin machen.

[code:1]deb http://ftp.de.debian.org/pub/debian oldstable main contrib non-free [/code:1]

Aber wies aussieht ist das Kind schon in den Brunnen gefallen. Und deshalb ein schwieriges wenn nicht sogar unm?gliches unterfangen, es sei denn man hat starke Nerven.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

10

12.05.2007, 11:01

Alles klar. Danke f?r die Tipps. Das alte Teil scheint nicht mehr zu retten. Da ich die DVD mit Knoppix 5.2 aus der ct hier liegen habe, werde ich es mal mit dem kopieren des DVD-Image auf die Festplatte versuchen (tohd) . Das Installieren tue ich mir nicht mehr an.

Sch?nes WE und Ciao

11

12.05.2007, 15:40

Hallo Allerseits,

Neuinstallation mit Knoppix DVD 5.2 hat funktioniert. :)

Nur trau ich mich nicht, das Verzeichnis "Boot" von der alten Knoppix-3.6-Installation zu l?schen, da dort die Datei "Menu.lst" drinsteht, die meinen Bootloader Grub steuert.

Dazu zwei Fragen:

Braucht Grub den Zugriff auf diese Datei bzw. kann man die woanders hin verschieben?
Kann ich Grub so einstellen, dass zum Booten des Images von Festplatte die DVD nicht gebraucht wird und wenn ja wie?

Ciao

12

12.05.2007, 19:07

Mit tohd hab ich noch nicht installiert. Falls aber bei der neuen Installation ein eigenes Verzeichnis f?r den Grub angelegt worden ist kann du das alte l?schen. Aber normalerweise braucht Grub die darin enthaltenen Dateien. Die menu.lst sollte klar sein wofur die ist. Stage_1 ist der Grub selbst. Der besteht ja nicht aus dem was Im Bootsektor ist . In 446 Bytes kann kein Bootlader untergebracht werden. Im Bootsektor sind noch 64 Bytes Partitonstabelle und 2 Kennungsbytes untergebracht. Stage_1.5 und Stage2 versetzen Grub in die Lage das Dateisystem zu lesen. Zumindest insoweit das der Kernel und eine eventuell vorhandene Initrd gelesen werden k?nnen. Sonst nix. ?nder doch mal die Farbe in der alten menu.lst und schau was passiert.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

13

12.05.2007, 22:06

Die Option tohd ist ja auch keine richtige Installation. Sie kopiert nur die Daten des DVD-Images auf die Festplatte. Daher braucht es auch keinen Bootloader.

GRUB war nur ohnehin vorhanden, weil ich das alte 3.6er Knoppix mal richtig ordentlich installiert hatte und als Parallelinstallation mit dem anderen OS betrieben habe. Somit gibt es auch kein neues Boot-Verzeichnis. Was mit "Farbe ?ndern" gemeint ist habe ich nicht verstanden....:-(

Das Problem ist, dass GRUB bei seiner Installation mal gesagt bekommen hat, wo seine Menu.lst physisch auf der Festplatte steht. Da er die meisten Dateisysteme selbst lesen kann, schaut er dann bei Stage 2 einfach auf diese Stelle und f?hrt aus, was ihm in der Menu.lst aufgetragen worden ist.

Das Dumme ist nur, dass er ja letztendlich auch mittels Chainloading das Win-OS startet und falls er besch?digt wird, funktioniert das auch nicht mehr. Zwei Systemcrashs in einer Woche muss nicht sein....

14

13.05.2007, 18:21

Und wenn ich das Richtig verstanden habe, dann wird nur das Image auf die Platte kopiert , und der Rest unangetastet lassen also auch grub.
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

15

13.05.2007, 20:32

Hallo Allerseits,

das Problem ist gel?st. Knoppix Installation mit tohd auf die Festplatte war erfolgreich. Habe danach das Verzeichnis /boot von der DVD auf die gleiche Partition kopiert und die menu.lst meines Bootloaders auf dieses Verzeichnis+Dateien darin angepasst.

Eine tolle Hilfe war ?brigens das Howto und die Beitr?ge f?r die Poor-Mans-Installation in der Abteilung "HD-Installation" (Wer lesen kann, ist klar im Vorteil...)

Funktioniert einwandfrei - kein l?stiges Booten mehr von DVD. Einziger Unterschied zum Start von DVD ist , dass die Zeichengr??e des farbigen Startbildschirmes wesentlich g??er als normal ist. St?rt mich aber nicht - schont eben die Augen.... ;-)

Ciao und Danke.

Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop