12.12.2018, 09:25 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

FM_81

Fortgeschrittener

1

20.02.2009, 11:18

KNOPPIX 6 auf EXT2-formatiertem USB-Stick

Das neue KNOPPIX auf einem FAT-formatiertem Stick aufgebracht => funktioniert tadellos (auch als Multiboot)!

Nun hätt' ich's gern auf einem der in EXT2 formatiert ist. (Zur Info, dort sind schon ein halbes Dutzend Live-Systeme drauf, also er funktioniert; auch die KNOPPIX-5.1-Version ging.) Nur KNOPPIX 6 weigert sich beharrlich automatisch zu starten:

Quellcode

1
Konnte DISK nicht nach 'mnt-system' ...
blablabla und so weiter. Mach ich aber in der aufgehenden Debug-Shell

Quellcode

1
mount /dev/sda1 /mnt-system
und beende diese mit Crtl-D startet es. SDA1 wurde allerdings kurz zuvor bei der Suche schon mit vergeblich "durchgerödelt". Nun hätte ich aber gern, daß es automatisch geht, wie man es gewohnt war? Ich hab' mir auch schon das INIT-Script in der minirt.gz angeschaut, eigentlich sollte (nach meinem Verständnis) es auch EXT2, EXT3 und ReiserFS, ja sogar NTFS automatisch durchsuchen.
Sollte ... tut es aber anscheinend nicht ... bzw. findet nichts ...

Hat jemand eine Ahnung, was da los ist?

Vielen Dank, FM_81
ACHTUNG!
Ihre Systemleistung reicht nicht aus, um einen BLUE-SCREEN zu erzeugen!
Möchten Sie statt dessen einen GREEN-SCREEN sehen?

---- [Ja] ---- [Nein] ---- [Weiß noch nicht] ----

2

03.03.2009, 02:10

Ich habe genau das gleiche Problem, welches ich hier auch schon gepostet habe.

Ich will auch auf einem USB-Stick mehrere Livesysteme haben, allerdings habe bisher auch nur das gleiche workaround gefunden. Wenn du schon eine L;sung hast, dann melde dich doch nochmal.

3

03.03.2009, 14:22

So,
Ich glaube, ich habe den Fehler gefunden.
Im init -Script steht in der Funktion trymount:

Quellcode

1
2
3
4
5
6
7
8
9
trymount(){
 mount -t vfat -o "$RW",umask=000,shortname=winnt,noatime "$1" "$2" || \
  mount -t iso9660 -o ro "$1" "$2" || \
   ntfs-3g -o "$RW",umask=000,force "$1" "$2" || \
    mount -t reiserfs "$RW",noatime "$1" "$2" || \
     mount -t ext3 "$RW",noatime "$1" "$2" || \
      mount -t ext2 "$RW",noatime "$1" "$2"
 return "$?"
}

Müsste da aber nicht eigentlich stehen:

Quellcode

1
2
3
4
5
6
7
8
9
trymount(){
 mount -t vfat -o "$RW",umask=000,shortname=winnt,noatime "$1" "$2" || \
  mount -t iso9660 -o ro "$1" "$2" || \
   ntfs-3g -o "$RW",umask=000,force "$1" "$2" || \
    mount -t reiserfs -o "$RW",noatime "$1" "$2" || \
     mount -t ext3 -o "$RW",noatime "$1" "$2" || \
      mount -t ext2 -o "$RW",noatime "$1" "$2"
 return "$?"
}


Dadurch würde sich mein Problem, dein Problem und auch Probleme mit ReiserFS lösen, oder?

Im Anhang liegt dann die fertige minirt.gz drin, für alle die das gleiche Problem haben.
(Nagut, ich sehe gerade, hier darf man nur 200kB hochladen. Also stelle ich es mal auf meiner Seite zur Verfügung, es wird aber nicht lange dort sein, alle paar Monate wird aufgeräumt ;) )
minirt.gz

Ich würde das auch gerne den Entwicklern mitteilen, wo muss ich mich da melden?

FM_81

Fortgeschrittener

4

03.03.2009, 16:32

Hab's jetzt noch nicht gegenprüfen können, aber so wie Du es beschreibst, scheint es durchaus plausibel.
Habe die INITRD selbst schon fünfmal auseinandergenommen und das Script inspiziert, aber manchmal sieht man den Wald vor lauter Bäumen nicht!

EDIT 06.03.09 - Erfolgsmeldung: ja es klappt und vielen Dank an georf ...

PS: Es geht aber auch alles auf einer Partition.

MfG, FM_81
ACHTUNG!
Ihre Systemleistung reicht nicht aus, um einen BLUE-SCREEN zu erzeugen!
Möchten Sie statt dessen einen GREEN-SCREEN sehen?

---- [Ja] ---- [Nein] ---- [Weiß noch nicht] ----

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »FM_81« (06.03.2009, 09:59)


klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

5

03.03.2009, 18:38

Hallo!

Zuerst startete ich Knoppix 6.0.1 von CD. Anschließend richtete ich auf einem 4 GB USB-Stick eine Linux-Partition ein und formatierte diese mit dem ext2-Dateisystem. Eigentlich wollte ich nun mit der Installationsroutine aus dem Systemwerkzeuge-Menü Knoppix auf dem Stick installieren lassen. Syslinux meldete jedoch, dass es sich um kein FAT-Dateisystem handelte. Daraufhin nahm ich einen zweiten USB-Stick von derselben Sorte wie den ersten, auf welchem ich bereits erfolgreich ein FAT32-Dateisystem mit Knoppix 6.0.1 installiert hatte. Ich kopierte alle Dateien auf den ersten Stick und ersetzte danach die minirt.gz durch die neue von georf. Außerdem kopierte ich syslinux.cfg nach extlinux.conf und führte im Wurzelverzeichnis meines ersten USB-Sticks

Quellcode

1
extlinux --install . 
aus. Ich entfernte nach erfolgreicher Installation die USB-Sticks und beendete Knoppix 6.0.1. Danach bootete ich vom USB-Stick mit dem ext2-Dateisystem und erhielt nicht mehr die bekannte Fehlermeldung.

Vielen Dank an georf für die erfolgreiche Korrektur.

Gruss Klaus

RalfonLinux

Erleuchteter

Beiträge: 2 936

Geschlecht: Männlich

6

03.03.2009, 18:41

Zitat

Ich würde das auch gerne den Entwicklern mitteilen, wo muss ich mich da melden?
Den Entwicklern ist ein Entwickler.

Solltest du auf der CeBit rum laufen, kannst du es ja mal am Heise-Stand probieren.
Oder beim Rheinland-Pfalz-Stand C39-28 in Halle 9

Er heißt Klaus, und KNOPPIX heißt KNOPPIX, weil er KNOPPER mit Nachnamen heißt.

Ralf
Auf Wunsch gibt es nur noch Text und keine Bilder mehr in der Signatur.
Keine ? ....... :evil:

Quellcode

1
2
3
4
5
6
7
8
.
    ~
   - -          M
   /V\         - *
  // \\        /V\
 /( _ )\      // \\
  ^~ ~^      /( _ )\
              ^~ ~^

7

23.03.2009, 01:46

Das Knoppix von Klaus Knopper kommt, habe ich auch schon mitbekommen ;-). War immerhin irgendwann mal die erste Linux-CD, die ich ausprobierte. Aber ich dachte, dass er heute schon ein paar Leute gefunden hat, die ihn ein bisschen unterstützen. Vor allem, wo das jetzt alles auf LXDE umgestellt wurde. Da hat man dann doch bestimmt etwas mehr zu tun.

Aber wie erreiche ich ihn denn? In dem Knoppix-Wiki habe ich dazu auch nichts gefunden...

klaus2008

Meister

Beiträge: 2 700

Geschlecht: Männlich

8

23.03.2009, 10:28

Hast Du schon eine E-Mail versucht? Seine Mail-Adresse findet man auf der Seite http://www.knopper.net/kontakt/?kontakt=knopper

Gruss Klaus

9

23.03.2009, 11:58

Zitat

Klaus Knopper hat derzeit über 4500 noch zu beantwortende Nachrichten in seiner Mailbox, daher beträgt die Antwortzeit für Fragen durchschnittlich 4 Wochen, gezählt von Versanddatum Ihrer Nachricht.


Das kann ja ne Weile dauern, bis das korrigiert wurde. Naja, ich werde die Datei noch ein bisschen liegen lassen. So groß ist die ja auch nicht

EDIT:
Er hat mir schon geantwortet:

Zitat

Hallo allerseits,

Besten Dank, den Fehler haben schon einige gefunden. Ist in der nächsten
Version schon repariert. :-)

Immerhin bis zum ntfs-3g hatte es funktioniert, alle anderen Mounts
gingen automatisch schief.

Viele Grüße
-Klaus Knopper

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »georf« (23.03.2009, 13:58)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop