22.11.2017, 23:02 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: Knoppix Forum | www.KnoppixForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

18.10.2017, 20:41

Failed to install override security policy (14): not found..

hallo forum

habe das knoppix 8.1 per ftp von der uni kiel heruntergeladen...(elend langsam trotz 400mbit)

mit der dvd kann ich den etwas älteren U36JC-RX über ein externes usb dvdLWstarten...läuft prima.

nun habe ich das knoppix auf einem sandisk ultra 32 Gb 3.0 stick installiert..

wenn ich den rechner nun starte, kommt folgende meldung: "failed to install override security policy : (14) not found

wenn ich den stick ohne overlay partition erstelle = es der gleiche fehler.

uefi kann ich im setup auf disabled stellen. ändert aber nichts an der meldung...

da ich kein kenner vom fantastischen knoppix bin, frage ich hier ob jemand einen tipp für mich hat...

ansonsten bleibt mir nur knoppix von dvd zu starten , was zwar langsam ist aber dafür sicherer ? oder ?

freundschaft !!

ubuntuli

Fortgeschrittener

Beiträge: 388

Geschlecht: Männlich

2

18.10.2017, 23:42

Hallo Ampersand
"failed to install override security policy : (14) not found

deutet darauf hin das auf deinem USB Stick kein bootloader im mbr installiert ist.

3

19.10.2017, 00:55

Wie hast du was installiert?

Das deutet eher auf ein falsches Boot-Environment des EFI.
Nun ist das unbedingt erstaunlich, wenn die DVD damit gelaufen ist, denn, wir stellten erst letztlich fest, dass sie das wohl eher nicht kann. Auf den wenigen Testrechnern die ich verfügbar hatte, funktionierte die DVD nur im BIOS-Modus und es gibt Rechner, die hier automatisch umschalten, sodass man das nicht einfach bemerkt.
Diese Umschaltung wird bei einem Stick nun nicht passieren.
Ein Stick kann aber EFI-Boot und Knoppix ist darauf vorbereitet.
Koppix 8.1 habe ich nur zum Test mittels dd auf einen Stick gebracht und das kann im EFI-Modus booten.
Knoppix 7.7.1 nutze ich im EFI-Modus von einem Stick, der mittels Flash-Install bespielt wurde.
Wenn du versucht hast, eine HD-Installation auf dem Stick durchzuführen, dann wird die nicht EFI-tauglich sein. Das ist an der Stelle eine Vermutung von mir, die ich aber für angemessen halte. Es würde sehr schön zu deiner Beschreibung passen.
Bis auf die Aussage, dass du es auch ohne Overlay versucht hast, denn die fällt bei HD-Installation ja weg.

Aber am Besten beschreibst du erst, wie du installiert hast und wie dein Stick nun aussieht, also, welche Partitionen er hat und welche Dateisysteme dort eingerichtet sind. Du kannst ihn dir mit der funktionierenden DVD ansehen.
Sodann kannst du das mit einem funktionierenden System vergleichen. Interessant ist die EFI-Partition und welche Einträge es in EFI/BOOT gibt.
Knoppix hat dort:

Quellcode

1
2
3
pit@eee ~:- > ls /media/KNOPPIX/EFI/BOOT
BOOTIA32.EFI	HASHTOOL.EFI	LDLINUX.E32	LOADER.EFI
BOOTX64.EFI	KEYTOOL.EFI	LDLINUX.E64


Bei dir kommt eine Fehlermeldung, die eigentlich typisch ist, wenn die LOADER.EFI oder die BOOTX64.EFI fehlen oder kaputt sind (Bei AMD64-Architekturen).
Jedenfalls finde ich das so im Netz beschrieben.
Und das ist dann wieder merkwürdig, dass der Legacy-Modus ebenfalls versagt (also BIOS-Modus und nicht UEFI).
Man möchte fast meinen, dass der Stick nicht korrekt bespielt wurde.

4

19.10.2017, 13:22

Hi,

@Ampersand:

Es waere in der Tat sehr interessant zu erfahren, welche Rechner bzw.
Motherboards im EFI Modus von DVD bis zur vollen Funktionsfaehigkeit von
Knoppix booten.

Falls Du bestaetigen kannst, dass Dein Rechner das wirklich tut, waere
er erst der zweite nach Klaus Knoppers virtuellem PC mit qemu+kvm+OVMF.
Auf der Gegenseite stehen ein paar Macs, ein nicht naeher bezeichnetes
PC Mainboard, und mein virtueller PC mit aelterem qemu+kvm+OVMF.

Wir brauchen dringend mehr Testberichte mit Details zur Boot-Firmware und
natuerlich nur im originalen EFI Modus, nicht im altertuemlichen BIOS Modus.

Nun zu Knoppix auf USB Stick:

Da gibt's die schon laenger bekannte "Installation" vom laufenden Knoppix
auf einen USB Stick.

Seit 8.0 gibt es aber auch die "isohybrid" Methode, bei der das ISO als
Platten-Image direkt auf den Geraetefile des USB Sticks kopiert wird.
Auf einem Unix-artigen System kann man das mit dem Programm "dd" machen.
Angenommen wir haetten ein GNU/Linux und der Stick hiesse /dev/sdc
(/dev/sdc1 oder ein gemountetes Filesystem vom Stick waere falsch)

Zuerst alle /dev/sdc* mit umount abhaengen. Dann:

Quellcode

1
2
dd if=/dev/sdc bs=1M | gzip >stick_vor_knoppix8.gz
dd if=KNOPPIX_V8.1-2017-09-05-EN.iso bs=1M of=/dev/sdc

Nun ist der Stick durch das Knoppix Image partitioniert und hat drei
Filesysteme: ISO mit Live-System, EFI System Partition im FAT Format,
ReiserFS als schreibbare Partition. Das ReiserFS wird beim ersten Start
von Knoppix bis zum Ende des Sticks ausgedehnt.

Spaeter mal kann man das Knoppix wieder durch den Backup ersetzen:

Quellcode

1
gunzip < stick_vor_knoppix8.gz | dd bs=1M of=/dev/sdc

Danach sind die alten Partitionen und Filesysteme wieder da.

Auf MS-Windows kann man ein Programm names "win32diskimager" benutzen,
oder das Program "Rufus" im "DD" Modus.
(Wie man auf MS-Windows den Backup macht, weiss ich nicht. Vermutlich
koennen die genannten Programme auch von Stick nach File kopieren.)


@ubuntuli:
MBR Code ist fuer BIOS wichtig, nicht fuer EFI. EFI braucht nur die
Partitionstabelle des MBR. Entweder gibt's dort eine Partition vom Typ "EF",
die dann die EFI System Partition ist, oder es gibt nur eine Partition,
die den Typ "EE" hat. Das "EE" besagt, dass es eine GUID Partition Table
gibt, in der dann eine EFI System Partition vorkommen kann.


@pit234a:
Das Problem scheint hauptsaechlich ArchLinux zu treffen. Laut
https://github.com/systemd/systemd/issues/2627
steckt es in einem Programm namens PreLoader.efi. Das scheint ein Programm
zu sein, das man in der System Partition als /EFI/BOOT/BOOTX64.EFI ablegt,
damit es das Programm /EFI/BOOT/LOADER.EFI startet.
Der Preloader von
https://blog.hansenpartnership.com/wp-up…3/PreLoader.efi
ist identisch mit BOOTX64.EFI in den Partitionen von Knoppix 8.1 und
ArchLinux.
Ich finde aber den Text der Fehlermeldung nicht in diesem Programm.

Man fragt sich also, woher die Meldung auf Ampersands USB Stick kommt.

Have a nice day :)

Thomas

5

19.10.2017, 13:58

Man fragt sich also, woher die Meldung auf Ampersands USB Stick kommt.


Ja das ist wirklich interessant und ich bin schon ganz gespannt auf weitere Informationen.

Und ja, stimmt, alle Beschreibungen zu diesen Fehlermeldungen fand ich zu Arch-Linux.

6

19.10.2017, 14:11

bin ich EFI?

Dazu wollte ich noch die einfache Methode erwähnen, die ich dazu erlernt habe. Im gebooteten System in einem Terminal einfach:

Quellcode

1
> dmesg | grep EFI

nach entsprechenden Einträgen suchen lassen. Gibt es keine, hat man nicht in EFI gebootet.
Ich habe gerade eben keine Verbindung zu einem entsprechenden Rechner, um ein Beispiel zu zeigen.

Außerdem nenne ich immer häufiger alles nur noch EFI und nicht UEFI. Das ist eigentlich nicht korrekt und ich weise deshalb auf diesen Fehler hin.

7

19.10.2017, 14:34

Hi,

Zitat


Und ja, stimmt, alle Beschreibungen zu diesen Fehlermeldungen fand ich zu Arch-Linux.


Die Loesungen sind allerdings nicht speziell an ArchLinux gebunden.
Einer konnte sich helfen, indem er sein BOOTX64.EFI mit einem anderen
EFI-tauglichen Startprogramm ueberschrieben hat. Ein oder zwei haben
die Firmware des Rechners erneuert.

Es koennte also sein, dass eine gewisse Version des von Microsoft
zertifizierten Linux Loaders mit gewissen Versionen von EFI Firmwares
in manchen Rechnern nicht gut kann.

@Ampersand:
Wenn's geht, bitte die MD5 Pruefsumme des Files /EFI/BOOT/BOOTX64.EFI
in der EFI System Partition des Sticks bestimmen und hier zeigen.
(Alle Buchstaben in diesem Pfad koennten gross oder klein geschrieben
sein. Das ist leider ein kleines Ratespiel.)


Zitat

Quellcode

1
dmesg | grep EFI

Das klappt aber nur kurz nach dem Booten. Wenn man ein bisschen Uptime
hat, zeigt dmesg sowas nicht mehr an. Man findet im Web den Rat, nach dem
Directory /sys/firmware/efi zu schauen.


Have a nice day :)

Thomas

8

19.10.2017, 19:20

Hi,

ich muss mich ein bisschen korrigieren. Der Fehlermeldungstext kommt doch
im File /efi/boot/BOOTX64.efi in der Knoppix EFI Partition vor. Er beginnt
bei Byte 58880 und ist in UTF-16 kodiert. Zwischen je zwei ASCII/UTF-8
Zeichenbytes steht noch eine 0.

Damit ist dann die folgende URL als Sourcecode plausibel:
https://kernel.googlesource.com/pub/scm/…ter/PreLoader.c
Die Fehlermeldung steht in Zeile 49.
Laut UEFI 2.4, Table 224 bedeutet die "14" in der Fehlermeldung
"EFI_NOT_FOUND | The item was not found".
Wenn ich's recht verstehe, kommt es vom Funktionsaufruf BS->LocateProtocol()
in Zeile 259 von
https://kernel.googlesource.com/pub/scm/…curity_policy.c
aber zu der steht nicht viel in UEFI 2.4. Der Sourcecode verweist auf ein
"UEFI Platform Initialization manual (Vol2: DXE)".

Unser Preloader muesste aber auf jeden Fall versuchen, das Programm
"loader.efi" auszufuehren und im Misserfolgsfall melden

Quellcode

1
Failed to start loader.efi


@Ampersand
Siehst Du diese Meldung ?

Have a nice day :)

Thomas

9

20.10.2017, 08:25

Dank an Euch.

Ich werde versuchen die Fragen in den nächsten Tagen abzuarbeiten und zu beantworten wenn ich fachlich dazu in der Lage bin. Wollte den Startvorgang- beginnend mit dem Bios Eintrag- abfilmen & hier einstellen,aber das flimmert stark und ist nicht zu gebrauchen.

Es ist ein älterer Laptop Asus u36 jc 64bit auf dem NT 6.1 läuft...Bin auch eher etwas älter...Bitte also um Geduld

Das gestartete Knoppix 8.1 läuft wirklich gut. Grafik , Nic & Co werden erkannt.

Beim Start mit Usb : Die Meldung "Failed to start loader.efi" sehe ich nicht. nur den Bluescreen mit OK Button. Das wars


Soll ich Screenshots erstellen und raufladen?

MFG Ampersand

10

20.10.2017, 09:31

Hi,

wenn die Meldung "Failed to install override security policy" das letzte
ist, was man vor dem Bluescreen sieht, dann wuerde ein Screenshot nicht
gross weiter helfen.
Das Fehlen der Meldung "Failed to start loader.efi" kann an zu schnellem
Bluescreen liegen oder daran, dass BOOTX64.EFI oder LOADER.EFI abstuerzen
und deshalb die Meldung von BOOTX64.EFI nicht mehr abgesetzt werden kann.

Weiterhin raetselhaft bleibt, warum die DVD keine Probleme macht. Da waere
ein Versuch mit dem ISO, das mit "dd" auf einen USB Stick kopiert wurde,
interessant. Wenn das ordentlich bootet, dann liegt das Problem zumindest
teilweise in der EFI System Partition auf dem Stick, der nicht bootet.
(Ein anderer Teil des Problems liegt ziemlich sicher in der EFI Firmware,
die nicht so reagiert, wie es BOOTX64.EFI erwarten darf.)

Zum Alter:
Eins, zwei, drei, im Sauseschritt
Laeuft die Zeit. Wir laufen mit.
(Wilhelm Busch)

Have a nice day :)

Thomas

11

20.10.2017, 15:34

Hi,

was passiert eigentlich, wenn Du den "OK" Knopf drueckst ?

In
https://kernel.googlesource.com/pub/scm/…r/lib/console.c
ruft die Funktion console_error() die Funktion console_alertbox() auf,
die console_select() mit dem "selectors" Text "OK" aufruft. (Ich vermute mal
dass "selectors" die Knoepfe sind. console_yes_no() hat ZB. zwei davon.)

Nach dem "OK" muesste dann der Versuch kommen, LOADER.EFI zu starten.
Wenn das fehlschlaegt, muesste wieder eine Meldung-in-der-Box kommen.
Entweder "Failed to start LOADER.EFI" oder die laengliche im Code danach:
"Failed to start loader ... I will now execute HashTool for you to do this"


Have a nice day :)

Thomas

12

23.10.2017, 20:34

Failed to install override security policy (14): not found.. » Neue Antwort erstellen

ich bleibe am ball. habe die vermutung das es am -alten- rechner liegt...habe dann mal zu testzwecken das aktuelle mint heruntergeladen & mit rufus auf einen usb stick installiert. das läuft einwandfrei...So werde ich unterschiedliche usb sticks testen...Nur ohne Persistenz möglich.

Nachtrag: Wenn ich die Fehlermeldung "Failed to install override security policy (14): not found.." mit OK weiterklicke, bin ich wieder im Bios.

Habe Testweise Tails 32 und 64 bit auf USB Stick installiert. Läuft beides. Nur die Pestilenz lässt sich in keinem Fall aktivieren.

Muss also an meinem Rechner liegen. Ich scheine also keine Referenz zur Fehlerbeurteilung zu sein...Sorry

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Ampersand« (24.10.2017, 19:23)


13

28.10.2017, 00:50

Knoppix läuft von USB Stick einwandfrei

hallo forum: ich habe nicht aufgegeben und weiter nach ursachen gesucht.

das win7 lief nicht im uefi sondern im bios modus. gab da eine info in win....gibt's das ? na ja der rechner ist ja schon älter

folgendes kam dabei heraus: mein rechnerbios hat zwar die bootauswahl: Uefi usb ,aber das hat nicht funktioniert. kam ja immer die fehlermeldung: Failed to install override security policy (14): not found..ein ok drücken liess den rechner wieder im bios landen..Nur beim starten über dvd lief es...

uefi habe ich nun deaktiviert (disabled) denn eine einstellung weiter rechts im bios gibt es ein "bootselektions menü"

unabhängig davon was ich im bootmenü einstelle, taucht dort die hdd (win7) auf UND der usb stick (oder eine externe usb festplatte die ich auch getestet habe)

dann wähle ich den usb stick aus und:

starte damit einwandfrei knoppix

das system ist auch persistent, dh es speichert alle einstellungen. nur mein kleiner usb audio adapter lässt sich nicht aktivieren. so sind es nur die laptoplautsprecher die die wiedergabe von klang ermöglichen. vrmtl findet knoppix keinen treiber für das billigteil (in win & auch in tails&min läuft das aber) . ist halt so...

NACHTRAG: der vlc player erkennt den usb audio adater einwandfrei. nun ist halt vlc der standardplayer. der usb stick (billigteil) wurde immer langsamenr. nun läuft knoppix über eine alte ide hdd per billig usb<--> ide adapter....die inst auf dem stick ist dann für das "mitnehmen"

achso ja: den stick/die usbHDD habe ich aus dem installationmenü der dvd heraus erstellt.... folglich: Knoppix rules !

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Ampersand« (28.10.2017, 23:02)


Linux HardwareLinux Computer & PCs | Linux Notebooks & Laptops | Geek Shirts | Geek und Nerd Shirt Shop